VestaCp after installing PHP7 Roundcubemail stopped working

0
3
Error: Roundcube mail reinstalling in vesta cp

There is a webserver with Centos 7 under the control of Vesta CP, I decided to install PHP 7 on it. The installation was successful, all sites work, but access to mail via the web interface is lost. When trying to connect to the url http://domain.com/ webmail in the browser, an error
  Not found
The requested URL / webmail was not found on this server.
I go to the roundcubemail directory, / usr / share / roundcubemail and see that it has only the plugins folder and nothing else. Reinstall roundcubemail
  yum install –y roundcubemail 
Next, open /etc/httpd/conf.d.roundcubemail.conf
  vi /etc/httpd/conf.d.roundcubemail.conf 
We are looking at the beginning of the file for the line Alias ​​/ webmail / usr / share / roundcubemail. If there is a line, then we do nothing, if not, then we write it, my file looks like this
  #
#Round Cube Webmail is a browser-based multilingual IMAP client
#
Alias ​​/ roundcubemail / usr / share / roundcubemail
Alias ​​/ webmail / usr / share / roundcubemail
restart httpd
  systemctl restart httpd 
After that, the page http://domain.ru/ webmail should open. If an error occurs
  You don't have permission to access / webmail / on this server 
Then open the file / webmail / usr / share / roundcubemail again and edit the next section
  <Directory / usr / share / roundcubemail />
<IfModule mod_authz_core.c>
# Apache 2.4
Require local
</IfModule>
<IfModule! Mod_authz_core.c>
# Apache 2.2
Order Deny, Allow
#Deny from all
Allow from all
Allow from :: 1
</IfModule>
</Directory>
on
  <Directory / usr / share / roundcubemail />
Order Deny, Allow
Deny from all
Allow from all
</Directory>
Remember to restart httpd with the systemctl restart httpd command. Now webmail opens, but when authorization is attempted, an error appears The connection to the IMAP server failed . I look at dovecot logs
Same issue. Appear after php update. Fixed by reverting
roundcubemail.conf
from
roundcubemail.conf.rpmsave.

  tail -f /var/log/dovecot.log 
I see a mistake
  Error: user [email protected]: Initialization failed: namespace configuration error: inbox = yes namespace missing 
Edit the file /etc/dovecot/conf.d/15-mailboxes.conf
  vi /etc/dovecot/conf.d/15-mailboxes.conf 
By adding the inbox = yes parameter
That is, in the beginning should be
  namespace inbox {
inbox = yes
#mailbox name {
Restart dovecot
  systemctl restart dovecot 
After which everything worked fine

Error “Invalid request! Information not saved. ”

After some time, when I tried to log into webmail, the error “Invalid request! Information not saved. ”

LEAVE A REPLY

Please enter your comment!
Please enter your name here